Вариант 6

Углубленный уровень

   1.

Какое количество информации получит второй игрок при игре в крестики-нолики на поле 16х8, после первого хода первого игрока, играющего крестиками?

  4 бита  
5 бит
6 бит
7 бит

2.
В процессе преобразования растрового графического изображения количество цветов увеличилось с 16 до 256. Во сколько раз увеличился  объем, занимаемый им в памяти?
  в 16 раз  
в 8 раз
в 4 раза
в 2 раза

3.
Преобразовать число 2316  в восьмеричную систему счисления ...
  35  
43
73
23

4.

Сложить числа 118 и 1110. Сумму представить в двоичной системе счисления.

  10010  
10001
10110
10100

5.

 Какова таблица истинности логической функции F= &

 

A

B

F

A

B

F

A

B

F

A

B

F

0

0

0

0

0

1

0

0

1

0

0

1

0

1

0

0

1

1

0

1

0

0

1

0

1

0

0

1

0

1

1

0

0

1

0

1

1

1

1

1

1

0

1

1

0

1

1

1

6.

Логическое выражение AÚ0 равносильно:

  1  
0
A

7.

Упростить логическое выражение AÚ

   
0
1
A

   8.

Фрагмент программы, в котором значения двумерного массива задаются с помощью вложенных циклов, записан на различных языках. Определите, какое значение приобретет элемент массива A[3,2].

Бейсик

Алгоритмический язык

For n=1 To 5

For k=1 To 5

If n>k Then A(n, k)=(n+k)

Else A(n, k)=(n*k)

Next k

Next n

нц для n от 1 до 5

нц для k от 1 до 5

если n>k

то А[n, k]=(n+k)

иначе A(n, k)=(n*k)

кц

кц

 

2 3 5 6

 

  9.

Что будет напечатано на форме в результате выполнения программы, записанной на объектно-ориентированном языке программирования Visual Basic?

Dim bytA(1 To 100), M, I, N As Byte

Sub Command1_Click()

For I = 1 To 100

bytA(I) = Int(Rnd*100)

Next I

M = bytA(1)

For I = 2 To 100

If bytA(I)< M Then M = bytA(I): N = I

Next I

Form1.Print N

End Sub

  значение минимального элемента массива
индекс минимального элемента массива
значение максимального элемента массива
индекс максимального элемента массива

 

  10.

В глобальной компьютерной сети Интернет протокол маршрутизации Internet Protocol (IP) обеспечивает ...
  передачу информации по заданному адресу  
разбиение передаваемого файла на части (пакеты)
получение почтовых сообщений
передачу почтовых сообщений